Serious Sam HD The First Encounter PROPER-SKIDROW-[tracker.BTARE

seeders: 2
leechers: 0
updated:
Added in Games > Windows
Torrent verified. Downloaded 165 times.

Serious Sam HD The First Encounter PROPER-SKIDROW-[tracker.BTARE (Size: 971.23 MB)
  sr-sshd.iso 971.22 MB
  skidrow.nfo 10.8 KB

Related Torrents

torrent name size files age seed leech

Sharing Widget


Download torrent
971.23 MB
seeders:2
leechers:0
Serious Sam HD The First Encounter PROPER-SKIDROW-[tracker.BTARE



To share this torrent use the code below and insert it into comments, status messages, forum posts or your signature.

Torrent: Serious Sam HD The First Enc...ROPER-SKIDROW-[tracker.BTARE

Trackers

tracker name
udp://tracker.openbittorrent.com:80/announce
udp://tracker.publicbt.com:80/announce
udp://tracker.istole.it:80/announce
udp://fr33domtracker.h33t.com:3310/announce
µTorrent compatible trackers list

Locations

name
ThePirateBay
Torrentzap
TorrentReactor
Torrent hash: fb0f8db7d3ae865818e6ba30ec2d2e7396b4840f

Top Comments

4
anonymous
very good game...works very smoothly with window 7.
4
anonymous
Hi people This is a fix for SSHD TFE For those of you who can´t save just open the game in Administrator mode. To do this in Windows 7, 1.right click the shortcut 2.select 'Run as Administrator'. Or open the file in it´s properties 1. open the shortcut and select 2.'Run as administrator', this way it will always start in administrator mode. and thus you can save
3
Schlappschwanz4
I love you Skidrow!!!!!!! Works great (like always)
3
anonymous
Does not work on Windows 7 64-bit. Crack copied from SKIDROW folder on .iso to Bin folder on hard drive. Launcher starts but clicking 'Launch' does nothing. Tried running SamHD.exe directly. Tried running as administrator. Tried every compatibility mode. Nothing works. Too bad because Second Encounter HD and SS3 both work fine (not cracked by SKIDROW). BAD CRACK. Need Real Proper.

All Comments

please, leave only comments related to that torrent
Sign In

Does it work on Win 7 64-bit?
can u play online?
cant open in windows xp
doent start in windows 8.1 ..its sayin cant read selected data language
I can not open.. error "the operation completed successfully" please help me....
1. Unpack release
2. Mount image or burn it
3. Install it
4. Copy the content from the SKIDROW directory on the DVD to your installation directory and overwrite
5. Play

-- Cleaner instructions lol
Thanks now it works, but after 3:40 minutes of gaming the controls don't work!! When i go up it goes back, when i go left it goes right... I tried to restart the game or reinstall it, but the problem persists. I think it is a BUG. Please someone knows how to fix it.
You need to change controls in options

Not working on Windows 7 (64bit)
Show More All

User Opinions

Snnak_e1249, Jafaridze235, rav33n95, Wolfstone56, fredh21244, tva35, jflegare8814, Traspler5, omkarpp1, omkarp0 ... And 85 more
itorrentstuff606, cc_343574, lavinius_caras243, lukematt135, TheZexy47, danny_cavasin46, uska23, Nasko_zlet018, daitko13, oskar karlsson1 ... And 26 more
Report a bug Open chat